Weather related interruptions
Resolved
This incident has been resolved.
Posted Jan 25, 2020 - 08:00 AEDT
Investigating
We are currently investigating this issue.
Posted Jan 24, 2020 - 23:00 AEDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 24, 2020 - 22:59 AEDT
Investigating
Heavy rain in the Emerald area is causing temporary interruptions in Emerald Downs, Mayfair, Gindie, Echidna Valley and Juanita and surrounding areas.
Posted Jan 24, 2020 - 22:58 AEDT
This incident affected: QLD Network (Central QLD Network).