Sky Muster Plus partial outage
Resolved
This incident has been resolved.
Posted Aug 18, 2020 - 09:27 AEST
Investigating
NBN is currently investigating a partial outage on the Sky Muster Plus service that is causing disruptions to some services.
Posted Aug 17, 2020 - 17:59 AEST
This incident affected: NBN (NBN National).